Fix lỗi "The application requires one of the following versions of the .NET Framework"

Để compile các ứng dụng chạy trên Windows thì một yêu cầu bắt buộc là máy tính bạn phải có .NET Framework. Tuy nhiên trong một số trường hợp mặc dù đã có .NET framework cài đặt trên máy bạn vẫn nhận được thông báo lỗi như sau:

The application requires one of the following versions of the .NET Framework

Hoặc:

To run this application, you first must install one of the following versions of .NET Framework.

Thông thường các bạn sẽ nhấp chọn Yes và tải file cài đặt phiên bản được gợi ý và tiến hành cài đặt. Tuy nhiên trong khi tiến hành cài đặt bạn có thể sẽ gặp phải một lỗi khác như sau:

.NET Framework 4.7.1 or later is already installed this computer

Lúc này để khắc phục lỗi trên bạn cần chỉnh sửa lại nội dung của tập tin XLM chứa cấu hình cho .NET framework mà ứng dụng hỗ trợ.

Tìm tới dòng thiết lập phiên bản .NET framework và comment dòng này như sau:

Fix lỗi

Bạn cũng có thể thực hiện theo cách khác đó là chỉnh sửa cấu hình trên để sao cho phiên bản .NET framework cần chạy ứng dụng khớp với phiên bản API sử dụng, ví dụ:

<supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.7" />

Lúc này khi compile lại bạn sẽ thấy không còn gặp phải lỗi trên nữa.

Content must not be empty

Related Blog